Back to overview
Degraded
Elevated call connection latency
May 7, 2026 at 11:56pm UTC
Affected services
Voice Initialize
Resolved
May 8, 2026 at 1:40am UTC
Issue has been resolved
Affected services
Updated
May 8, 2026 at 1:35am UTC
Call success rate has recovered to 99%.
Affected services
Updated
May 8, 2026 at 12:56am UTC
The issue has been fully resolved. Call connection latency has returned to normal levels.
Affected services
Created
May 7, 2026 at 11:56pm UTC
An upstream issue caused elevated latency during call initialization, leading to >30s delays before the agent spoke after transfer. Some callers may have dropped before connecting.
A fix has been deployed and latency is back to normal. We're continuing to monitor.
Affected services