Back to overview
Degraded
Voice Connection Issues
May 28, 2026 at 3:30pm UTC
Affected services
Voice Initialize
Resolved
May 28, 2026 at 3:54pm UTC
The upstream issue has been resolved and call connection latency has returned to normal levels.
Affected services
Created
May 28, 2026 at 3:30pm UTC
We're seeing elevated call connection latency, with a portion of calls failing to connect before timing out. The issue appears to be caused by upstream voice infrastructure. We're actively investigating and engaging the provider.
Customers may experience higher-than-normal no-answer rates on voice calls during this period.
Affected services